Unable to Save or Enable AD Sync

An improperly defined installation path might lead to conflicts when saving management settings in the Savance Workplace Server console. Whether this is the core issue or not, the methods below can help enable AD Sync for your Savance Workplace server. This problem is often noticed when the save button remains clickable after pressing ‘Save,’ or when attempting to exit, you encounter the prompt illustrated in the image below:

Check the path that the EIOBoard server is taking.

  1. Open regedit from searching the start menu.
  2. Navigate to the EIOBoard Server.  In the example, it is under HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Savance\EIOBoardServer
  3. Ensure that the Path directs to the EIOBoard Server.  In the example, it is C:\Program Files (x86)\Savance\EIOBoard Server\
  4. If you had to make a change, restart the Savance Workplace Server Admin and check to see if the AD Sync can be saved now.

If AD Sync still cannot be saved, follow these steps to edit the registry and ‘web.config’ file:

  1. Navigate to EIOBoard Server Service in the registry: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Savance\EIOBoardServer\EIOBoard Server Service
  2. Add a new Dword 32 bit value named ‘ADEnabled’ with a value of 1.                                                         
  3. Proceed to the ‘web.config’ file located in the EIOBoard Server folder.  By default it will be located at C:\Program Files (x86)\Savance\EIOBoard Server\EIOBoard.
  4. Edit this file with the changes you would like:
  • Enable passwords through Active Directory, adjust the line:
    • <add key=”ValidatePasswordUsingActiveDirectory” value=”false” />
  • Ensure that your server address is correct in the line reading:
    • <add key=”ActiveDirectoryServerAddress” value=”SERVER ADDRESS” />
  • Ensure that your port is correct:
    • <add key=”ActiveDirectoryPort” value=”PORT” />
  • To validate passwords with SSL, modify:
    • <add key=”ValidatePasswordUsingActiveDirectoryWithSSL” value=”false” />
  • Ensure that the domain is accurate:
    • <add key=”ADDomain” value=”DOMAIN” />

If these steps have been taken and the problem persists, please contact support and note in your ticket that you have attempted these steps to no avail.

Was this article helpful?

Related Articles

Need Support?

Can't find the answer you're looking for?
Contact Support